GSDA:Obtaining NEXRAD Radar Data from NCDC

From XMS Wiki
Jump to: navigation, search

Obtaining NEXRAD Radar Data from the National Climatic Data Center (NCDC) requires two steps. First, you must order the data. Second, you need to convert the data to an ASCII grid format so WMS can recognize it. It is available from September 1996 until a few days from the present (availability does depend on the radar site).

Ordering Data from NCDC

There are two methods to order the data from NCDC. One method is using the 'NEXRAD Inventory Search Tool'. The other method is to order the data from the 'NCDC HDSS Access System (HAS). Method 1 is the simplest method if you need a single day of data for a single station.

Method 1: Using the NEXRAD Inventory Search (Recommended Method)

This method provides a map to help you determine the radar site closest to your watershed and will not require you to know the 4 digit acronym of the radar site (For example, Salt Lake City is KMTX. This is provided when a radar site is selected). It allows you to see the data that is available before making the order. It only allows you to order data one day at a time. It also allows you to order a specific product ("LVL3 - STORM TOTAL PRECIP (230 KM)" in our case) and select the files (time steps) you wish to order.

  1. Select the radar site closest to your watershed from National Doppler Radar Sites.
  2. Choose the date of the storm events that interests you.
    1. Note the reference timezone, and that you may need to convert your date.
  3. Select "LVL3 - STORM TOTAL PRECIP (230 KM)" for the product.
  4. Click Create Graph button.
    1. This graph will show which mode that the radar was operating under when collecting the data. The red or blue lines indicate times that data was collected. Typically this is around every four minutes, but occasionally the radar may be done for several hours or longer.
  5. Click the Order Data hyperlink.
  6. Enter your Email Address.
  7. Select the files you wish to download.
    1. The file name format is explained on the NCDC Radar Frequently Asked Questions (FAQ). Most importantly, the last block of numbers gives the year, month, day, hour, and minute that the data was collected.
  8. Click Order Data button.
  9. The final page will confirm that your order has been submitted and provide you a link to check on the status of your order. It generally takes less than 5 minutes to process your data and make it available on the ftp site. You can wait to receive the e-mail which will provide you with the ftp link to download the data, or you can use NCDC Java NEXRAD Viewer and Data Exporter to download your data. The details of how to use the Java NEXRAD Viewer and Data Exporter will be given in the convert data step

Method 2: NCDC HDSS Access System (HAS) (Advanced Method)

This method requires you to know the 4 digit acronym of the radar site that is closest to your watershed; however, you can download a Google Earth kmz file from the NCDC for this purpose: Nexrad.kmz. It only allows you to order data that may span days, months, or years. It will send all the products available for the specified time period in tar file format.

  1. Click on NEXRAD Level III Radar image hyperlink at the NCDC HDSS Access System (HAS) site.
  2. Select the Radar Station(s) of interest.
  3. Select Start and End Date.
  4. Enter your E-mail Address.
  5. Click the Continue with Selections button.
  6. Click the Retrieve Selected Files button.
  7. The final page will confirm that your order has been submitted and provide you a link to check on the status of your order. It generally takes less than 5 minutes to process your data and make it available on the ftp site. You can wait to receive the e-mail which will provide you with the ftp link to download the data, or you can use NCDC Java NEXRAD Viewer and Data Exporter to download your data. The details of how to use the Java NEXRAD Viewer and Data Exporter will be given in the convert data step

Convert the data to an ASCII grid format

The files obtained from the NCDC are given in a binary format that is foreign to WMS. So we will now convert them to a format that WMS can read.

  1. From the Java NEXRAD Tools webpage, click on the Install Now hyperlink.
  2. Click on the Launch the STABLE Version 3.6.6 Java NEXRAD Viewer (includes Data Exporter) Hyperlink located under the Java Web Start heading. This will install the Java program on your machine if it is the first time you have run the program. Subsequent visits will launch the program rather than installing it.
  3. If you wish to use the Java NEXRAD Viewer to download your data from the NCDC, enter your HAS number in the Data Selector dialog and click submit (The HAS number was given on the confirmation page and e-mail). If you have already downloaded your data, change the tab on the Data Selector dialog from NCDC to Local. Then click Browse, and select the folder that contains your data.
  4. You can now view your data by selecting a file, and clicking the Load button.
  5. In the Java NEXRAD Viewer Main window, click on the Data Menu, and select NEXRAD Data Exporter or hit Ctrl-E.
  6. The Java NEXRAD Data Exporter should have brought up your data in its list box. If it did not, follow the same routine you did earlier for the Data Selector dialog.
  7. Click on the Format Menu, and Select ESRI ASCII Grid file format.
  8. It is recommended that you change the grid size of the exported ASCII Grid.
    1. Click on the Options Menu and select Raster Options.
    2. You can Change either the Square Grid Size or Grid Cell Size (deg) but the other will need to be set to Auto. Choosing a large value will reduce the time required by WMS to process the data. Choosing the a small value will give you more resolution. It is recommended that you increase the size of the grid cells.
      1. A Grid Cell Size (deg) of 0.0100 will yield roughly 20 points in a basin of 7 square miles (depending on shape) while a Grid Cell Size (deg) of 0.0250 will yield roughly 400 points in a basin of of 1,000 square miles (again, depending on shape).
    3. Click the OK button.
  9. Select the files you wish to export.
    1. If you used Method 2 to collect your data, you will see all the data products that are available instead of only the Total Storm Precipitation. Be sure to only select the files that have NTP in the product designation. More information on filename format in the NCDC Radar Frequently Asked Questions (FAQ).
  10. Click the Browse button and select the folder you wish to place the exported ASCII grids.
  11. Click the Export button.
  12. When the program finishes, the data is ready to be brought into WMS.

Metadata

About the Data

The data you have now downloaded and converted gives the cumulative depth of the precipitation in inches since the beginning of the storm (the data and time of the beginning of the storm is shown when the data is loaded in the NCDC Java NEXRAD Viewer and Data Exporter. The data is given in geographic coordinates. A projection file (prj) is included for viewing within ESRI ArcGIS. Projection files are not read by WMS. Because the data is cumulative, you do not need to use every timestep provided by the NCDC. It is recommended that you choose a regular interval (for example, an hour), and select the files that are the closest to these time intervals.

Using Radar Data in WMS

Follow the steps given WMS site