SMS:What's New in SMS 12.0

From XMS Wiki
Jump to navigationJump to search

Release Notes

SMS 12.0 was released as a Beta in March 2015 in conjunction with the new National Highway Institute course entitled Two-Dimensional Hydraulic Modeling of Rivers at Highway Encroachments (NHI Course 135095). This update of SMS includes several new capabilities and advancements which are outlined below.

IMPORTANT NOTE: CMS Modelers should NOT update their licenses to use this version of the package. The developers of CMS-Flow and CMS-Wave are in the process of updating their models. The interfaces associated with these updates were intended to be included with this release. However, due to delays in the development cycle, the new version of CMS and the associated interface will not be available until later this year. For applications of CMS, users are encouraged to continue to use SMS version 11.2.

General Features

Model Interfaces

Modules

  • New Quadtree Module will be utilized in the future for CMS-Flow or other models that perform computations on a quadtree geometry.

Contours

  • A new command has been added to the Data menu to populate the contour range from either the visible or selected nodes/vertices. The Data menu has two new commands:
    • Set Contour Min/Max – this command sets the contour options based on the current options and the selected nodes/vertices or zoom level.
    • Contour Range Options – This allows the user to control if the Set Contour Min/Max command applies to dataset specific contour options or the general contour options (for the mesh or scatter modules). It also sets the flags for precision and fill above and below.

Performance Enhancement

  • Cell selection for large grids.
  • The time required to merge two meshes and the options when performing these types of merged were sped up and improved.

Preferences

  • The Preferences dialog now allows users to specify third-party help using the Dynamic Model Interface Schema.
  • The settings option now allows the user to reset the settings to either factory defaults or the users specified defaults.

Projections

  • The functionality of the display projection was modified to make it more intuitive. If the user specifies a projection, it will be used for all data being loaded into the system. If the display projection is "Local" or "Not projected" and data with a projection is loaded, an inconsistency is created. At that point, SMS requests that the user specify the desired projection to use for display.

Rotate Tool

  • The Rotate tool now rotates around the center of the graphics window rather than using the center of x, y, and z coordinates of the data. This allows users to more easily rotate around specific areas of the model.

Module Features

Quadtree Module

  • Telescoping grids have been expanded into a more versatile Quadtree Module.
  • The Map→Quadtree command has been added.

GIS Module

  • The GIS module has been revised to include all Geographic Information data including:
    • Images
    • CAD Data - Better data extent information on layer by layer basis
    • Shapefiles
    • Rasters/DTM/DEM – new display options for Rasters, new interpolation options
  • GIS objects are opened in SMS using the Global Mapper library unless specific functionality for a file type is supported.
  • GIS objects loaded into SMS can support
    • Color data (images)
    • Elevation data (DTM)
    • Raster data (land use)
    • Vector data (features)
  • SMS includes tools to convert between formats and extract data from the GIS objects.

Map Module

  • SMS can now force an arc from a coverage into an existing mesh/unstructured grid or TIN. The command creates new nodes/vertices and forces the arc as a breakline. Elevations for the new nodes can be assigned from the arc to force a new feature into the geometry or from the mesh/TIN to only force connectivity.
  • A new clean option was added to look for "near" intersections. If an node is within the specified tolerance of another arc, the node is snapped to the arc. This can be thought of as the corollary to intersecting two arcs that just barely overlap and deleting the resulting dangling end.
  • SMS now autoselects the scatterset/dataset for interpolation onto a polygon if there is only one scatterset and it only has one dataset.
  • SMS can now select arcs/nodes by attribute type.

Scatter Module

  • SMS now includes an option to optimize all or part of a TIN triangulation using a smooth contour algorithm. This algorithm attempts to minimize the variability or jaggedness of contours in the selected region by swapping triangle edges. This is an addition to the two previous optimization methods that utilized minimum angles (Delaunay) or minimum triangle area variation.

Distance Tool

  • SMS now computes distances between two selected vertices on a TIN in both 2D and 3D space. The info options control which values are displayed.

Model Features

ADCIRC

  • In ADCIRC when there is a weir boundary condition on two nodestrings, the user can right-click on the nodestrings and now there is a new menu called Remove Weir. Selecting this brings up a dialog asking the user if they want to pave over the weir or merge nodestrings which will result in new nodes down the center.
  • There is a new menu item called Add Weir when right-clicking on a single boundary condition nodestring. This brings up a dialog asking the user what width they want for the weir. When OK is clicked a new weir is created.
  • New option to more efficiently search hurricane storm paths in the HURDAT storm database. When opening the the data base SMS now displays a dialog that allows the user to filter by date range, intensity, location (storm must pass within specified distance of specified point). The user can then select the desired storm/storms and load them into SMS as hurricane coverages.
  • SMS now supports the ice-field option that is has been added to the ADCIRC model in version 51.

CMS-Flow/CMS-Wave

  • The interfaces to CMS Flow and CMS Wave are not included in SMS 12.0. These interfaces, along with an updated version of the CMS numerical models, will be available in SMS 12.1. Current CMS users should continue to use SMS 11.2.

GenCade

  • A new option to support Adaptive Time Stepping was added to the interface.
  • A new option to support Tidal Current was added to the interface.
  • Issues related to setup when generating a GenCade model were resolved.
  • Support for an enhanced Inlet Reservoir Model was added.
  • An SBAS Connection was added to the interface.
  • Support for spatially variable parameters was added to the interface.

Generic Model Interface/2dm files

  • A preference has been added to allow the user to specify the precision used when writing a 2dm geometry file.
  • Since the addition of support for multiple meshes in SMS 11.2, the interface now allows multiple generic model interface templates to be loaded at the same time. An option was also added to allow the user to remove/delete a template that is loaded and is no longer needed. This command is in the Edit menu in the Mesh module.
  • When duplicating a coverage of type Generic Model Interface, all attributes of arcs, nodes and polygons are now preserved in the duplicate.

SRH-2D

  • The SRH-2D interface has been modified to use a simulation based modeling approach rather than the traditional mesh/grid based approach. This allows the user to create a mesh/grid without associating it with a specific model.
    • A simulation is then created near the bottom of the project explorer by right-clicking and selection the New Simulation command and selecting the appropriate type.
    • Components of the simulation including the geometry, boundary conditions, material zones, monitor lines and points, etc are associated with the simulation by linking the geometry or coverages to the simulation. Linking can be accomplished by right-clicking or drag/drop.
    • Simulation attributes are specified by right-clicking on the simulation and selecting the appropriate command(s).
    • Simulations can be duplicated and edited to represent multiple scenarios in a single SMS project.

STWAVE

  • STWAVE now runs all spectra as time values.
    • This means that the solution is loaded as a single dataset with time steps for each spectra.
    • Each input spectra is associated with a date/time.
    • The user can control the reference date for a simulation.
  • STWAVE now supports ice datasets.
  • Spectral coverages have been added to store the spectral data used to represent wave states.
    • Spectra in a spectral coverage are full plane spectra with source specified frequency and directional parameters.
    • Spectra in a spectral coverage can be globally oriented (North = 0) or locally oriented depending on the source.
  • New boundary condition specification
    • User specifies the resolution of half or full plane spectra to be generated for an STWAVE simulation.
    • Boundary condition can be specified as a spectral coverage with a single spectral site to match historic operation.
    • Boundary condition can be specified as a spectral coverage with multiple spectral sites to allow for spatially varied boundary similar to previous nested simulations.
    • Boundary condition can be specified as a parent/child relationship.

TUFLOW

  • User can now right-click on the TUFLOW root tree item to remove all simulations.

What's New in SMS

Bugfixes