GMS:Converting 3D Meshes to Other Data Types

From XMS Wiki
Jump to: navigation, search
3D Mesh Module
Sample FEMWATER.JPG
3D Mesh
Creating a 3D Mesh
Editing a 3D Mesh
Converting 3D Meshes to Other Data Types
More
3D Mesh Display Options
3D Mesh Tool Palette
ADH Display Options
Solids to Layered Mesh
3D Mesh Commands

3D mesh nodes can be converted to 3D scatter points bye using the following command in the Mesh Menu:

Mesh to 3D Scatter Points

The Mesh → Scatter Points command in the Mesh menu is used to create a new scatter point set using the nodes in a mesh. A copy is made of each of the datasets associated with the mesh and the datasets are associated with the new scatter point set.

This command is useful for comparing the solutions from two separate simulations from different meshes. For example, if two simulations have been performed with slightly different meshes (base vs. plan) it may be useful to generate isosurfaces or a fringe plot showing the difference between the solutions. It is possible to generate a dataset representing the difference between two datasets using the data calculator. However, the two datasets must be associated with the same mesh before the data calculator can be used. The datasets from one of the meshes can be transferred to the other mesh as follows:

  1. Load the first mesh and its dataset into memory.
  2. Convert the mesh to a scatter point set using the Mesh → Scatter Points command.
  3. Delete the first mesh by selecting the Delete All command from the Edit menu.
  4. Load the second mesh and its dataset into memory.
  5. Switch to the 3D Scatter Point module and select an interpolation scheme using the Interpolation Options command in the Interpolation menu.
  6. Interpolate the dataset to the second mesh by selecting the to 3D Mesh command from the Interpolation menu.

At this point, both datasets will be associated with the second mesh and the Data Calculator can be used to compute the difference between the two datasets. This same sequence of steps can be used to interpolate a dataset from a 3D grid to a 3D mesh, or vice versa.

3D Mesh to 2D Mesh

This command creates a 2D mesh from the upward facing elements of the 3D mesh. The materials of the 3D elements are preserved on the 2D mesh. The datasets associated with the 3D mesh are NOT transferred to the 2D mesh.

Mesh to Solids

This command will convert each material zone in the 3D mesh to a solid.