GMS:Editing 2D Meshes

From XMS Wiki
Jump to: navigation, search
2D Mesh Module
2d mesh.png
2D Mesh
Creating a 2D Mesh
Editing 2D Meshes
2D Mesh Settings
Converting a 2D Mesh to Other Types of Data
More
2D Mesh Display Options
2D Mesh Polygon Attributes
2D Mesh Tool Palette
SEEP2D
Solids to Layered Mesh
2D Mesh Commands

Editing Nodes

Insert Node

New nodes in a 2D mesh are created by selecting the Create Nodes tool from the 2D Mesh Tool Palette and clicking where the new node is to be located. The default parameters governing the creation of new nodes can be specified using the 2D Mesh Settings command in the Mesh menu. This brings up the Node Options dialog.

Delete Node

A set of selected nodes can be deleted by hitting the Delete key or selecting the Delete command from the Edit menu. If the deleted node is connected to one or more elements, the action taken when the node is deleted depends on the status of the options in the 2D Mesh Settings dialog.

If the Retriangulate voids when deleting option is turned on, the void created when a node and the elements surrounding the node are deleted is re-triangulated or filled in with triangles. This feature makes it possible to selectively "unrefine" a region of the mesh or reduce the density of the nodes in a region of the mesh without having to completely recreate all of the elements in the region.

If the Retriangulate voids when deleting item in the Node Options dialog is not set, the selected node and the elements surrounding the node are simply deleted and the resulting void is not filled in with triangles.

If the Confirm Deletions option in the Edit menu is active, GMS will ask to confirm each deletion. This feature is helpful in preventing accidental deletions. The Confirm Deletions item is toggled by selecting it from the menu.

Move Node

The coordinates of a 2D mesh node can be edited by selecting the mesh node and entering the new coordinates in the edit boxes in the Edit Window. It is also possible to drag an existing node to a new location by clicking on the node and moving the mouse with the button held down until the node is in the desired position.

If the Snap to Grid option in the Drawing Grid Options dialog is set, the node will move in increments corresponding to the drawing grid. If the node being dragged is connected to one or more elements, GMS will not allow the node to be dragged to a position where one of the surrounding elements would become ill-formed.

Since it is possible to accidentally drag points, nodes can be "locked" to prevent them from being dragged by selecting the Lock All Nodes item from the Mesh menu. The nodes can be unlocked by unselecting Lock All Nodes from the Mesh menu.

Editing Elements

Convert Between Linear and Quadratic

Linear elements (three node triangles and four node quadrilaterals) can be converted to quadratic elements (six node triangles and eight node quadrilaterals) and vice versa by selecting the Convert Elements item from the Mesh menu.

If there are both linear and quadratic elements in the mesh (as may be the case with a disjoint mesh), a prompt will ask to specify the type of conversion desired; linear to quadratic or quadratic to linear.

Merging Triangles

The triangulate operation creates a mesh composed entirely of triangles. In some cases it is desirable to have the mesh composed primarily of quadrilateral elements. Quadrilateral elements result in a more concise mesh which leads to faster solutions, and quadrilateral elements are often more stable numerically. To address this need, two options are provided for converting triangular elements to quadrilateral elements: The Merge Triangles command, the Merge/Split Tool.

The Merge Triangles Command

The Merge Triangles command in the Modify Mesh menu can be used to automatically merge pairs of adjacent triangular elements into quadrilateral elements. Upon selecting the Merge Triangles command, a prompt will ask to input a minimum interior angle. This angle should be between 0o and 90o. If no elements are selected, all of the triangular elements in the mesh are then processed. If some elements have been selected, only the selected elements are processed. The conversion process works as follows:

  1. The set of elements to be processed is traversed one element at a time. Each triangular element that is found is compared with each of its three adjacent elements. If the adjacent element is a triangle, the trapezoid formed by the triangle and the adjacent triangle is checked.
  2. Each of the four interior angles of the trapezoid is computed and compared to a minimum interior angle. If all of the angles are greater than the user-specified minimum interior angle, then the two triangles are merged into a single quadrilateral element.

This process is repeated for all of the elements. The merging scheme will not always result in a mesh composed entirely of quadrilateral elements. Some triangular elements are often necessary in highly irregular meshes to provide transitions from one region to the next.

The Merge/Split Tool

The other option for merging triangles involves the use of the Merge/Split tool in the 2D Mesh Tool Palette. This tool can be used to manually merge triangles one pair at a time rather than using the automatic scheme described above.

The manual method is also useful to edit or override the results of the automatic merging scheme in selected areas. The Merge/Split tool can also be used to undo a merge. A quadrilateral element can be split into two triangles by clicking anywhere in the interior of the element. This tool is useful if a pair of triangles is inadvertently merged.

Splitting Quadrilaterals

Occasionally it is necessary to split quadrilateral elements into triangular elements. For example, in order for new nodes to be automatically inserted into a mesh, the elements in the region where the node is inserted must be triangular. Also, in order to process a breakline, the elements in the region of the breakline must be triangular. In such situations, it may be necessary to split a group of quadrilateral elements into triangular elements. Two options are provided for splitting quadrilateral elements:

  • The Split Quads Command – The Split Quads command in the Mesh menu can be used to split a group of quadrilateral elements into triangular elements. If no elements are selected, all of the quadrilateral elements in the mesh are split. If some elements have been selected, only the selected quadrilateral elements are split.
  • The Merge/Split Tool – The other option for splitting quadrilateral elements involves the use of the Merge/Split tool in the 2D Mesh Tool Palette. If the Merge/Split tool is selected, clicking anywhere in the interior of a quadrilateral element with the mouse cursor will cause the element to be split into two triangles. The shortest diagonal through the quadrilateral is chosen as the common edge of the two new triangular elements

Refining Elements

In some cases, a mesh does not have enough elements in a particular region of the mesh to ensure stability. Rather than inserting supplemental nodes and re-creating the mesh, it is possible to refine a selected region of the mesh using the Refine Elements command in the Mesh menu. This increases the mesh density of a selected area of the mesh. If no elements are selected, the entire mesh is refined. The elevations of the new nodes are interpolated from the existing nodes.

Change Element Materials

Elements can have a material ID associated to it. The Materials command in the Edit menu brings up the Material Editor dialog. The material ID associated with the element can be changed using the Properties command in the Edit menu. (See Materials)

Boundary Triangles

The perimeter of the TIN resulting from the triangulation process corresponds to or approximates the convex hull of the TIN vertices. This may result in some long thin triangles or "slivers" on the perimeter of the triangulated region. There are several ways to deal with the long thin triangles. Thin triangles can be selected and deleted using the normal selection procedures. There is also an option for selecting thin triangles when the Select Triangles tool is selected. If the Control key is held down, it is possible to drag a line with the mouse. All triangles intersecting the line are selected. Long thin triangles on the perimeter of the TIN can also be selected by selecting the Select Boundary Triangles command from the TINs menu. The Select Boundary Triangles command checks triangles on the outer boundary first. If the length ratio of the triangle is less than the critical length ratio, the triangle is selected and the triangles adjacent to the triangle are then checked. The process continues inward until none of the adjacent triangles violate the minimum length ratio. The critical length ratio for selecting thin triangles can be set by selecting the TINs | TIN Settings menu command. The length ratio is defined as the longest side of the triangle divided by the sum of the two shorter sides.

Breaklines (a) Triangulated Mesh and Breakline. (b) Triangulated Mesh After the Breakline has been Processed.

Breaklines

A breakline is a feature line or polyline representing a ridge or some other feature to be preserved in a mesh made up of triangular elements. In other words, a breakline is a series of edges to which the triangles should conform to, i.e., not intersect.

Breaklines can be processed using the Add Breaklines command from the Mesh menu. Before selecting the command, one or more sequences of nodes defining the breakline(s) should be selected using the Select Node Strings tool in the 2D Mesh Tool Palette.

As each breakline is processed, the triangles intersected by the breakline are modified by adding new nodes at necessary locations to ensure that the edges of the triangles will conform to the breakline. The elevations of the new nodes are based on a linear interpolation of the breakline segments. The locations of the new nodes are determined in such a way that the Delauney criterion is satisfied.