WMS:CAD Data

From XMS Wiki
Jump to: navigation, search

Opening CAD Files

WMS uses a third party set of DLLs to read CAD files. This is done so that WMS can stay current with evolving changes in DXF and other file formats. Previously, only limited DXF support was provided, and only for files exported from AutoCAD release 12 or earlier. This interface not only provides expanded and up to date support of DXF, but AutoCAD DWG files are also supported. MicroStation DGN files can also be opened.

WMS can use CAD files as base map (background) information to the project, and to convert some CAD features into feature objects of the current coverage. CAD layers can be managed in the Project Explorer in the GIS module.

Saving CAD Data

Most of the data objects within WMS (e.g. coverages, contours, etc.) can be converted to CAD layers. Once converted to CAD layers these data can be saved to either a DXF or DWG (AutoCAD native file format) using the Save As command in the File menu. The Save As option will only save the current CAD layers to the file so convert WMS data to CAD prior to saving if desiring to have data created in WMS saved to a CAD format.

Deleting CAD Data

The Remove command in the right-click menu of the CAD data CAD Folder.svg item is used to delete all CAD data. It is not currently possible to delete individual layers, but the visibility of a layer can be controlled from within the Display Options dialog.

CAD Display Options

The objects in CAD files are organized into layers. The display of layers in a CAD drawing is controlled using the Display Options command in the CAD menu. This command brings up the CAD Display Options dialog, shown below.

CAD Display Options dialog.

The CAD Display Options dialog has been removed starting in WMS 10.1.

List of Layers

The names of the layers in the drawing are shown in the box on the left of the dialog. A check mark appears to the left of the names. The visibility of a layer is controlled using these toggles. All of the layers can be made toggled on/off with the option for All that is at the top of the list.

Colors/Styles

With the current implementation of the new CAD data colors and styles are inherited from the original drawing and cannot be changed from within WMS.

Converting WMS Data to CAD

If wanting to convert WMS data objects such as feature object coverages, TINs, contours, etc., choose the Save As option in the right-click menu for each coverage or dataset then save the object as a *.dwg/*.dxf file. This will convert the various WMS data objects into separate CAD layers which can be controlled from the Display Options dialog. The colors of the layers will be inherited based on the current WMS display options settings for the individual objects.

At the current release polygon data types are not supported in the conversion from WMS to CAD, however arcs that make up polygons, or triangles that make up color-filled contours are saved as layers.

Example

To export a delineated watershed with only the watershed boundary displayed, follow these steps:

  1. Select Display menu then Display Options... .
  2. Select Map Data on the left side of the Display Options dialog.
  3. Make sure that only the Generic (under Arcs) box is checked in the Map tab of the Display Options dialog.
  4. Right-click on the DEM item under Terrain Data in the Project Explorer.
  5. Select Delete.
  6. Switch back to the map module by either selecting Map Data in the Project Explorer or the Map Module macro at the top of the screen.
  7. Select the Select Feature Arc tool in the map module toolbar.
  8. Delete each of the stream arcs by selecting each with the Select Feature Arc tool.
  9. Make sure the Map module is active (see step 6).
  10. Right-click on the Map coverage and select Save As... and save the file as a *.dwg/*.dxf file.

How to convert a floodplain boundary to a CAD drawing

  1. Right-click on the flood depth dataset and set the contour options to normal linear, specified values, and a single contour with a value of 0.001 .
  2. Right-click on the TIN, select convert, select TIN Contours→Feature.
  3. Remove any unwanted arcs from the floodplain boundary.
  4. Delete any data not needed to export (TIN, area property coverage, 2D scattered data).
  5. Right-click on the Map coverage and select Save As... and save the file as a *.dwg/*.dxf file.

Converting to Feature Objects

Many times CAD data layers are used to create streams, watersheds, or other feature objects. To do this, first convert the CAD data to feature objects. This is done by choosing the CAD To | Feature Objects command in the CAD data item Convert to CAD Icon.svg right-click menu and then specifying which objects in the layer are to be converted. Alternatively, the GIS Data folder GIS Folder.svg can be right-clicked and the Data → CAD option selected. The newly created files below the CAD data folder Convert to CAD Icon.svg is then right-clicked and the and the CAD To | Feature Objects command is selected. When converting data, either add it to the currently active coverage or have a new coverage created. Once the data have been converted it is a good idea to delete the CAD data or at least toggle of the visibility.

Converting to TIN

Sometimes digital elevation data are stored in CAD files in the form of 3D points and 3D faces. These CAD objects can be converted to TINs using the CAD To | TIN command in the CAD data item Convert to CAD Icon.svg right-click menu. Alternatively, the GIS Data folder GIS Folder.svg can be right-clicked and the Data → CAD option selected. The newly created files below the CAD Data folder Convert to CAD Icon.svg is then right-clicked and the and the CAD To | TIN command is selected. After converting the data it is a good idea to delete the CAD layers, or at least turn off their visibility.

Related Topics