WMS:Editing Cross Sections

From XMS Wiki
Jump to: navigation, search

For the new 1D Hydraulic Cross Section coverage, the cross section geometry is stored in text database file on disk. When extracting cross sections they are saved to a new (or existing) database file. However, extraction of cross sections from digital terrain models is not the only way that they can be created, nor is extraction always the only thing that needs to be done. For example, other ways cross sections can be entered for use include importing from a spreadsheet, or entering manually. In such cases, and many times after extraction from a digital terrain model, there are edits that must be performed in order to prepare the cross sections for hydraulic modeling.

Edit cross sections in one of three ways:

  1. Assign a cross section from a database by double-clicking on an arc in a 1D Hydraulic Cross Section coverage. After assigning the cross section, it also possible to enter the editor for that cross section.
  2. Open a cross section database for editing (or create a new database) using the Manage Cross Sections command.
  3. Open an existing cross section database using the Open command in the File menu.

The operations described in the following paragraphs can be done using the Cross Section Attributes editor shown in the figure below.

Cross Section Attributes editor

General Properties

In order to identify information about the cross section in the database a name (not required), a reach, a station, and the name of the topographic data used to extract the cross section (if applicable) can be defined. A note about the cross section can also be defined. Not all of these attributes are critical for the development of a hydraulic model, but they are useful in managing the cross section within a database.

Editing Geometry

Cross section points can be added, or values edited when the Geom Edit tab of the editor is active. XY values are available when the actual 3D position of each point on the cross section is known. The more traditional D-Z pairs define the distance from the starting point and a corresponding elevation.

Geo-Referencing

Geo-referencing information provides the spatial (xy) location of the cross section and included geometry. This information is inherent in the 3D coordinates, when extracting cross sections from a digital terrain model. However, if the cross section geometry is taken from a survey then the actual xyz coordinates of the points may not be known. In order to use the data within WMS for floodplain delineation, a proper geo-reference must be provided.

A cross section can have one of the following georeferencing definitions:

  • All points specified (extracted cross sections will be of this type)
  • Use two points (e.g. the coordinates of the beginning and ending location along the cross section defined)
  • Use one point and angle (e.g the centerline location is known and some angle relative to it defined)
  • No georeferencing defined.

The geo-referencing is defined from the Geo Ref tab in the Cross Section Attributes editor.

Line Properties

Line properties define segments of material properties along the cross section. When using an area property coverage during extraction from a digital terrain model these properties are automatically marked and defined. However, they can also be established manually from within the Line Props tab in the Cross Section Attributes editor.

Point Properties

Point properties include thalweg, left bank, and right bank (other properties can be defined but are not mapped/saved to hydraulic models from within WMS) locations. When using a centerline and bank line arcs from a 1D Hydraulic Centerline coverage during extraction these points are marked. WMS can also "Auto Mark" these points by looking for the lowest elevation (thalweg), and appropriate breaks in elevation/slope (banks). Point properties are edited from within the Point Props tab in the Cross Section Attributes editor.

Merging

It is possible to combine a surveyed cross section with a section extracted from a terrain model for the floodplain (e.g. the terrain model does not contain enough detail to define the cross section of the river) using the tools in the Merge tab in the Cross Section Attributes editor. Two different cross sections can be merged, with rules for locations and precedence defined in order to create a new cross section.

Filtering

It may be that there are more points defining the cross section than are necessary (or that the hydraulic model is capable of processing). The Filter tab in the Cross Section Attributes editor allows specifying rules for filtering "insignificant" points along the cross section. This can be particularly important when extracting cross sections from a dense digital terrain model.

Related Topics