GMS:File Menu

From XMS Wiki
Jump to: navigation, search
GMS Commands
Common
File
Edit
Display
Modules
TINs
Boreholes
Solids
Mesh (2D)
Grid (2D)
Scatter Points (2D)
Interpolation (2D and 3D)
Mesh (3D)
Grid (3D)
Scatter Points (3D)
Feature Objects
GIS
UGrid
Models
FEMWATER
MODAEM
MODFLOW
mod-PATH3DU
MODPATH
MT3DMS
SEAWAT
SEEP2D
T-PROGS
UTEXAS

The File menu is one of the standard menus and is available in all of the modules. The commands in the File menu are used for file input and output for the basic GMS file types, for printing, and to exit the program. The following commands are contained in the File menu:

New 
Deletes all data associated with all data types and all modules. It resets the status of the program to the default state that is set when the program is first launched. This command should be selected when an entirely new modeling problem is started.
Open 
This command is used to read in project files and to import data or other files generated outside of GMS.
Add Online Maps 
Allows importing data such as imagery and DEM data from the internet.
Save 
Used to save GMS projects. A project contains all of the files associated with a modeling project. When a GMS project is saved, all files associated with the data currently in memory are saved. This includes any model simulations which are open. By default the model simulation will be saved to the same location as the project. However, in the Save dialog the path for the model simulation can be specified.
Save As 
Used to designate the path for saving a GMS project. It can also be used to Export data.
Edit File 
Prompts for the name of a file and opens the file in the chosen program. This command is used to edit model input files or to view output files. Output files that are part of a Solution can also be viewed by double-clicking on the text file in the Project Explorer.
Settings... 
This command can be used to change the default settings (display options, units etc) applied to all new projects. For example, if wanting new projects to have particular settings, set those up in GMS and then use the Settings command to to save the Current settings as the defaults to be used in the future. It is also possible to stop using defaults that were set previously and restore the defaults to the Factory defaults. There is only one set of default settings.
Page Setup
Launches the Page Setup dialog. The Page Setup dialog contains 3 tabs: Margins, Options, and Paper Size. The Options tab allows specifying the printing scale. The Paper Size tab allows selecting the paper size and source. Also, the orientation, portrait or landscape, can be selected. The Margin tab allows changing the Margins. On the right side of each tab is a print preview.
Print
Printed copies of the current GMS image are generated with this command. This launches the standard Windows Printing dialog.
Layout 
Launches the XMS Layout dialog for defining print layouts.
Recent File List 
Near the bottom of the File menu is a list of recently opened projects. As many as five different files can be in the recent file list.
Exit 
Terminates the program.

Related Topics