GMS:Toolbars

From XMS Wiki
Jump to: navigation, search
ToolPalettes.jpg

There are several toolbars that can be displayed in the GMS interface. Below are the toolbars that are on by default.

Basic Macros

Some of the more frequently used menu commands can be accessed through the macro buttons.

GMS Macro toolbars.png

File Menu Macros

The following File menu commands appear as macros on this toolbar:

  • New New Macro.svg – Resets settings to the defaults and creates a new untitled project.
  • Open Open Macro.svg – Brings up the Open dialog and allows an existing project or other file to be imported into GMS.
  • Save Save Macro.svg – Brings up the Save As dialog. It allows the current project to be saved as a GPR file and a variety of other formats.
  • Print Print Icon.svg – Brings up the Print dialog, allowing the contents of the Graphics Window to be printed to any printer supported by Windows.

Display View Macros

The following Display menu commands appear as macros in this toolbar. They can also be accessed by selecting either Display or Display | View and selecting the desired tool.

  • Plan View Plan View Macro.svg – Changes the view to a top-down display, like on a blueprint.
  • Front View Front View Macro.svg – Changes the view to a front elevation display.
  • Side View Side View Macro.svg – Changes the view to a side elevation display.
  • Oblique View Oblique View Macro.svg – Changes the view to a 3D perspective.
  • Ortho Mode Ortho View Macro.svg – Changes to an orthagonal, or layer, view. This is only available when using the 3D Grid.
  • Frame Image Frame Macro.svg – Brings all the project extents within the boundaries of the Graphics Window.

Other Macros

The following Display and Edit menu commands appear as macros in this toolbar. They can also be accessed by selecting either Display or Edit and selecting the desired tool.

  • Display Options Display Options Macro.svg – Brings up the Display Options dialog.
  • Properties GMS Properties Macro.svg – Brings up the Properties dialog for the selected element.
  • Refresh Display Refresh Macro.svg – Refreshes the Graphics Window.
  • Use Light Source Lighting Options Macro.svg – Turns on or off the Lighting Options. The settings are accessible through the Display Options dialog (see above).
  • Plot Wizard Plot Wizard Macro.svg – Brings up the Plot Wizard dialog.
  • Contour Options Contour Options Macro.svg – Brings up the Contour Options dialog.
  • Data Calculator Data Calculator Macro.svg – Brings up the Data Calculator dialog.
  • Materials GMS Materials Macro.svg – Brings up the Materials dialog.
  • Add Online Maps Add Online Maps Icon.svg – Brings up the Get Online Maps dialog.
  • Map Locator Map Locator Macro.svg – Brings up the Virtual Earth Map Locator dialog.

Display Visibility Macros

The following Display menu commands appear as macros in this toolbar. They can also be accessed by selecting Display | Visibility and selecting the desired tool.

  • Hide GMS Hide Macro.svg – Toggles off the visibility of the selected elements.
  • Show GMS Show Macro.svg – Toggles on the visibility of the selected elements.
  • Isolate GMS Isolate Macro.svg – Toggles off the visibility of all but the selected elements.

Contextual Macros

These macros appear or disappear according to which options and models are enabled or disabled.

Map To Macros

Includes commands for building polygons, running models, and for the mapping feature objects to geometric objects or numerical models. The available macros will change depending on the available data and project setup.

  • Build Polygons Build Polygons Macro.svg – Creates polygons out of closed arcs.
  • Map to TIN Map to TIN Macro.svg – Creates a TIN using each polygon in the coverage.
  • Map to 2D Mesh Map to 2D Mesh Macro.svg – Creates a 2D Mesh on the interior of all of the polygons in the current coverage.
  • Map to 3D Grid Map to 3D Grid Macro.svg – Opens the Create Grid dialog.
  • Map to UGrid Map to UGrid Macro.svg – Creates a UGrid from feature objects.
  • Map to 2D Scatter Map to 2D Scatter Macro.svg – Creates a scatter point set from the points and nodes and vertices of the current coverage.
  • Map to MODFLOW Map to MODFLOW Macro.svg – Converts a conceptual model to a MODFLOW numerical model.
  • Map to FEMWATER Map to FEMWATER Macro.svg – Converts a conceptual model to a FEMWATER numerical model.
  • Map to MT3DMS Map to MT3DMS Macro.svg – Converts a conceptual model to a MT3DMS numerical model.
  • Map to SEEP2D Map to SEEP2D Macro.svg – Converts a conceptual model to a SEEP2D numerical model.
  • Run MODFLOW Run MODFLOW Macro.svg – Initiates the MODFLOW executable.
  • Run MODPATH Run MODPATH Macro.svg – Initiates the MODPATH executable.
  • Run FEMWATER Run FEMWATER Macro.svg – Initiates the FEMWATER executable.
  • Run MODAEM Run MODAEM Macro.svg – Initiates the MODAEM executable.
  • Run MT3DMS Run MT3DMS Macro.svg – Initiates the MT3DMS executable.
  • Run SEAWAT Run SEAWAT Macro.svg – Initiates the SEAWAT executable.
  • Run SEEP2D Run SEEP2D Macro.svg – Initiates the SEEP2D executable.
  • Run UTEXAS Run UTEXAS Macro.svg – Initiates the UTEXAS executable.

Tools

Static Tools

The Static Tools contain the tools which are available in every module. These tools are for basic operations such as panning and zooming. Only one tool is active at any given time. The action that takes place when clicking in the Graphics Window depends on the current tool. The following table describes the tools in the Static Tools.

 Static tools.png
Tool Tool Name Description
Pan Tool.svg Pan The Pan tool is used to pan the viewing area of the Graphics Window. Panning can be done in 3 ways:
  • When the Pan tool is active, holding down the main mouse button while dragging moves the view.
  • If another tool is active and not wanting to switch tools, pan by holding down the F2 key and clicking and dragging with the mouse.
  • If the mouse has a middle button (or a mouse wheel), hold it down and drag to pan the view.
Zoom Tool Icon.svg Zoom The viewing area can be magnified/shrunk using the Zoom tool. Zooming can be done in the following ways:
  • With the zoom tool selected, clicking on the screen zooms the display in around the point by a factor of two. Holding down the SHIFT key zooms out.
  • With the zoom tool selected, a rectangle can be dragged around a portion of the display to zoom in on that region. Holding down the SHIFT key zooms out.
  • If another tool is active and not wanting to switch tools, zoom by holding down the F3 key and clicking and dragging with the mouse.
  • If the mouse has a mouse wheel, scroll the wheel to zoom in and out.
Rotate Tool.svg Rotate The Rotate tool provides a quick way to rotate the viewing location. Rotating can be done in the following ways:
  • With the rotate tool selected, holding down the mouse button and dragging the cursor in the Graphics Window rotates the object in the direction specified. A horizontal movement rotates the image about the z axis. A vertical movement rotates the image about the x and y axis.
  • If another tool is active and not wanting to switch tools, rotate by holding down the F4 key and clicking and dragging with the mouse.

(The viewing angle can also be entered directly via the View Angle command in the Display Menu.)

Measure Tool.svg Measure

The Measure tool provides a quick way to measure distances.

  • The tool is only available in plan view.
  • Measuring is done by selecting the tool and clicking on the Graphics Window with the mouse. A single line or a polyline can be created with a double-click used to end the line. The backspace key removes the last point clicked.
  • The distance from the last point and the total length are given at the bottom of the GMS window. The length units correspond to those selected in the Units dialog.
Get Data Tool.svg Get Data

The Get Data Tool is used to specify the location of interest for obtaining data using the import from web feature. Click and drag in the main graphics window to specify the area to be downloaded. The Data Service Options dialog will then appear and the web service or catalog can be selected for downloading the data. SMS will ask to save the data file before downloading the data and importing it into SMS. The data will appear in the GIS module.

This tool is not available if a display projection has not been specified. The tool will determine the data location based on the display projection.

Dynamic Tools

When the active module is changed, the tools in the Dynamic Tools change to the set of tools associated with the selected object/module.

 3D grid tools.png 3D Grid Tools – This is just an example of one of the Dynamic Toolbars

Mini-Grid Toolbar

The Mini-Grid Toolbar appears when a 3D grid exists and when the orthogonal viewing mode is active. In the orthogonal mode, the viewing angle is always parallel to one of the three grid axes (I, J, or K) and only one of the rows, columns, or layers is displayed at one time. The Mini-Grid Toolbar shows an idealized representation of the 3D grid and shows which of the rows, columns, or layers is currently being displayed. The current row, column, or layer can be changed using the arrows Increment up and down arrows.png on the Mini-Grid Toolbar.

MiniGridToolbar.png

Modules

The Modules toolbar is used to switch between modules. Only one module is active at any given time. Activating a module simply changes the set of available tools and menu commands.

Modules ToolBar.png

See also