SMS:Scatter Module Tools

From XMS Wiki
Jump to: navigation, search


The following tools are contained in the Dynamic Tools portion of the tool palette when the Scatter module is active. Only one tool is active at any given time. The action that takes place when clicking in the Graphics Window depends on the current tool. The following sections describe the tools in the Scatter tool palette.

Select Scatter Point

The Select Scatter Point Select Point Tool.svg tool is used to select scatter points (also known as vertices). A single point is selected by left-clicking directly on it. Multiple points can be selected at once by dragging a box. To drag a selection box, left-click and hold the button while dragging the mouse to the appropriate dimensions; release the button to enclose and select the contents. Additional scatter points can be appended to the selection list by holding the SHIFT key while selecting by any method. Selecting new points without holding the SHIFT key will first clear the selection list and then add the newly selected points. A selected point can be removed from the selection list by holding the SHIFT key as it is reselected. Pressing the ESC key will clear the entire selection list. Right-clicking will open a menu specific to this tool.

Scatter points are locked by default so they are not accidentally dragged, but can be unlocked using the Scatter Vertices menu. When a single point is selected, its location is shown in the Edit Window. The Z coordinates can be changed by typing in the edit field. The active scalar function is updated when the Z coordinate changes. If multiple points are selected, the Z Coordinate value shown is the average scalar value of all selected points. If this value is changed, the new value will be assigned to all selected points.

The Graphics Window’s status bar will display information on the selected items depending on the settings find through the File | Info Options command in the File Menu.

Selected scatter points can be deleted by selecting the Edit | Delete menu command on the Edit Menu, by pressing the DELETE or BACKSPACE keys, or from the right-click menu. Triangles attached to the deleted scatter points are deleted. The resulting void can be retriangulated.

This tool is available when one or more scatter points exist.

Right-Click Menu

  • Find – Available when nothing selected. Brings up the Find dialog to search for a vertex by ID or location. Like the menu command.
  • Scatter Options – Available when nothing selected. Brings up the Scatter Options... dialog. Like the menu command.
  • Triangulate – Available when nothing selected. Triangulates the entire scatter set. Like the menu command.
  • Select Thin Triangles – Available when nothing selected. Selects thin triangles around the boundary. 'Thin' is defined by the aspect ration in the scatter options. Like the menu command.
  • Delete Long Triangles – Available when nothing selected. Deletes long triangles around the boundary. 'Long' is defined by the aspect ration in the scatter options. Like the menu command.
  • Select All – Available when nothing selected. Selects all vertices.
  • Delete – Available when one or more vertices selected. Deletes the selected scatter vertex/vertices.
  • Split Breaklines – Available when one or more vertices selected. Splits all breaklines that go through the selected vertex into two breaklines (one on each side of the selected vertex). If the vertex is the end of the breakline or is not used in any breaklines, the command has no impact.
  • Assign Point Name... – Available when one or more vertices selected. Prompts for a name for the selected point. The default name will be "Point #" where '#' is the ID of the point. Points do not have names unless specifically specified. Names can be displayed in the Scatter module display options.
  • Clear Selection – Available when one or more vertices selected. Unselects all the selected vertices.
  • Invert Selection – Available when one or more vertices selected. Selects all the unselected vertices and unselects all the selected vertices. This can be useful when many vertices are to be deleted. First select those to be kept and then invert the selection.
  • Zoom to Selection – Available when one or more vertices selected. Recursively zooms in on the selected objects. Invoke this command multiple times to zoom in tighter.

Create Scatter Point

The Create Scatter Point Create Points Tool.svg tool is used to place new scatter point in a scatter set. A single point or vertex is created at a time by left-clicking at the coordinate desired. The newly created point is selected to allow Z coordinate changes in the Edit Window. Scatter points are locked so X and Y coordinates can not be edited.

This tool is always available, however, creating a scatter point is only allowed while in plan view.

Select Breaklines

The Select Breaklines SMS Select Nodestring Tool.svg tool is used to select breaklines. Holding the SHIFT key while selecting breaklines will add breaklines to the selection that are not already selected and remove breaklines that are already selected from the selection. Multiple nodestrings can be selected by dragging a box around the breaklines. Holding the CTRL key and clicking will enable selection with a polygon. Holding the CTRL key and dragging will enable selection with an arrow.

The Edit Window shows the number of breaklines selected.

Right-Click Menu

  • Delete Selected – Deletes the selected scatter breakline(s).
  • Merge Selected – Merges multiple breaklines that connect end to end into a single breakline. An error is reported if two (or more) breaklines are selected that do not have common end points or a single break line is selected.
  • Force Breaklines – Swaps the triangle edges that cross the selected breakline(s) to ensure no triangles cross the breakline(s).
  • Clear Selection – Unselects all the selected breaklines.
  • Zoom to Selection – Recursively zooms in on the selected objects. Invoke this command multiple times to zoom in tighter. If no breaklines are selected, this command zooms to all breaklines.
  • Select All – Selects all breaklines.

Create Breaklines

The Create Breaklines SMS Create Nodestring Tool.svg tool is used to create breaklines. Breaklines are used to control the connectivity of a scatter set. To create a breakline:

  1. Click on a scatter vertex. The vertex will be highlighted in red and a prompt will be shown in the Help Window.
  2. Click on any vertex to add it to the breakline. The selected vertex is also highlighted in red and a solid red line is drawn between the two vertices. Continue adding vertices to the breakline in this manner.
    Note: Vertices in the breakline can be adjacent, but this is not required. A breakline will usually be made of vertices which are not adjacent.
    1. Press the BACKSPACE key to backup one vertex. Press the ESC key to abort the breakline creation.
    2. Double-click a vertex or press the ENTER key to end the breakline creation.
  3. The SHIFT and CTRL keys assist in creating large breaklines which include sections made up of adjacent nodes. These can be used after at least one vertex has been selected and function as follows:
    1. SHIFT – Holding down the SHIFT key and selecting another vertex will add to the breakline all vertices between the two. The path chosen is the shortest distance between the two vertices that follows triangle edges.
    2. CTRL – Holding down the CTRL key and selecting another vertex will add to the breakline all vertices on the scatter set boundary between the two, going counter clockwise from the first vertex to the second vertex. Both vertices must be on the boundary of the scatter set or SMS will beep.
    3. CTRL + SHIFT – Holding down both the CTRL and SHIFT keys and selecting another vertex will add to the breakline all vertices on the scatter set boundary between the two, going clockwise from the first vertex to the second vertex. Both vertices must be on the boundary of the scatter set or SMS will beep.

Select Triangle

The Select Triangle SMS Select Mesh Element Tool.svg tool is used to select triangles. A single triangle is selected by clicking inside it. Multiple triangles can be selected at once by dragging a box or an arrow. To drag a selection box, left-click and hold the button while dragging the mouse to the appropriate dimensions; release the button to enclose and select the contents. To drag a selection arrow, left-click while holding the CTRL key (the CTRL key can be released after the click) and hold the mouse button and drag the mouse to form an arrow of the desired length and direction; release the button to impale and select the triangles through which the arrow passes. Additional triangles can be appended to the selection list by holding the SHIFT key while selecting by any method. Selecting new triangles without holding the SHIFT key will first clear the selection list and then add the newly selected triangles. A selected triangle can be removed from the selection list by holding the SHIFT key as it is reselected. Pressing the ESC key will clear the entire selection list. Right-clicking will open a menu specific to this tool.

When a single triangle is selected, its centroid location is shown in the Edit Window. If multiple points are selected, the Z value shown is the average scalar value of all selected triangles.

The Graphics Window’s status bar will display information on the selected items depending on the settings find through the File | Info Options command in the File Menu.

Selected triangles points can be deleted by selecting the Edit | Delete menu command on the Edit Menu, by pressing the DELETE or BACKSPACE keys, or from the right-click menu. The Scatter vertices (points) of the deleted triangles are not deleted. The resulting void can be retriangulated.

This tool is available when one or more scatter triangles exist.

Right-Click Menu

  • Select Thin Triangles – Selects thin triangles around the boundary. 'Thin' is defined by the aspect ration in the scatter options. Like the menu command.
  • Delete Long Triangles – Deletes long triangles around the boundary. 'Long' is defined by the aspect ration in the scatter options. Like the menu command.
  • Select All – Available when nothing selected. Selects all vertices.
  • Process Boundary Triangles – Available when nothing selected. Like the menu command.
  • Delete – Available when one or more triangles selected. Deletes the selected scatter triangle(s).
  • Clear Selection – Available when one or more triangles selected. Unselects all the selected triangles.
  • Invert Selection – Available when one or more triangles selected. Selects all the unselected triangles and unselects all the selected triangles . This can be useful when many triangles are to be deleted. First select those to be kept and then invert the selection.
  • Zoom to Selection – Available when one or more triangles selected. Recursively zooms in on the selected objects. Invoke this command multiple times to zoom in tighter.

Create Triangle

Most triangles in SMS will be created using automatic triangulation. At times, however, it is necessary to create a triangle, especially after deleting triangles. This is done using the Create Triangle SMS Create Linear Triangle Element Tool.svg tool.

To create a single triangle, select the vertices of the desired triangle by left-clicking on each scatter point or by dragging a selection box. As points are selected individually, they will be highlighted. Also, triangle edge will be drawn between the first and second vertex. To remove the last highlighted point from the desired triangle, press the DELETE or BACKSPACE keys. To abort the creation of a triangle, press the Escape key. When three points are selected, SMS will try to create the desired triangle. To drag a selection box, left-click and hold the button while dragging the mouse to the appropriate dimensions; release the button to enclose and select the contents. The selection box must only contain the three desired vertices to create the triangle. If the new triangle will overlap existing triangles the triangle will not be created. If more then three points are selected (via a selection box) then SMS will not attempt to create a new triangle.

This tool is available when three or more scatter points exist.

Swap Triangle Edge

The Swap Edges SMS Swap Edge Tool.svg tool is used to manually swap the edges of two adjacent triangles. This is useful in such cases as avoiding an artificial dam in a channel. Left-click on the desired triangle edge to swap it. The edges of the triangles will only be swapped if the resulting triangles are valid.

This tool is available when two or more scatter triangles exist. Swapping edges is only allowed while in plan view.

Create Mesh Nodes Contour

The Create Mesh Nodes Contour Add Contour Labels Tool.svg tool is used to temporarily display a Z value on a TIN. Click on a location to display the value. The labels will not reappear if the graphic window view changes.

This tool is available when at least one scatter triangle exists. Contour labeling is only allowed while in plan view.

Related Topics