SMS:Map Module Tools

From XMS Wiki
Jump to: navigation, search
Map Module
Map Data Set.png
Map
Feature Objects
Coverages
More
Map Module Interface
Map Display Options
Map Module Tools
Feature Objects Menu
Map Project Explorer

The following tools are contained in the dynamic portion of the Tool Palette when the Map module is active. Only one tool is active at any given time. The action that takes place when clicking in the Graphics Window depends on the current tool. The following table describes the tools in the map tool palette.

Tool Tool Name Description
SMS Select Node Tool.svg Select Feature Point or Node The Select Feature Point or Node tool is used to select stand alone feature points or the ends of arcs. A single point is selected by left-clicking directly on it. Multiple points can be selected at once by dragging a box. To drag a selection box, left-click and hold the button while dragging the mouse to the appropriate dimensions; release the button to enclose and select the contents. Additional points can be appended to the selection list by holding the SHIFT key while selecting by any method. Selecting new points without holding the SHIFT key will first clear the selection list and then add the newly selected points. A selected point can be removed from the selection list by holding the SHIFT key as it is reselected. Pressing the ESC key will clear the entire selection list. Right-clicking will open a menu specific to this tool.

Feature points are locked so they are not accidentally dragged. When a single point is selected, its location is shown in the Edit Window. The coordinates can be changed by typing in the edit field.

The Graphics Window’s status bar will display information on the selected items depending on the settings find through the File | Info Options command in the File menu.

Selected points can be deleted by selecting the Edit | Delete menu command on the Edit menu, by pressing the DELETE or BACKSPACE keys, or from the right-click menu. Arcs attached to the deleted points are deleted.

This tool is available when one or more feature points exist.

Create Points Tool.svg Create Feature Point The Create Feature Point tool is used to place new feature point in the current coverage. A single point is created at a time by left-clicking at the coordinate desired. The newly created point is selected to allow Z coordinate changes in the Edit Window.

This tool is always available, however, creating a feature point is only allowed while in plan view.

SMS Select Vertex Tool.svg Select Feature Vertex The Select Feature Vertex tool is used to select one or more vertices on an arc. These vertices define the shape of the arc. The vertex may have a "z" elevation specified, but no other attributes are associated with the feature vertices.
SMS Create Vertex Tool.svg Create Feature Vertex The Create Feature Vertex tool is used to create a new vertex on the interior of an arc. The vertex is created at the current arc location, but can be selected and moved to change the shape of the arc. The vertex may have a "z" elevation specified, but no other attributes are associated with the feature vertices.


SMS Select Arc Tool.svg Select Feature Arc The Select Feature Arc tool is used to select one or more existing feature arcs. This is typically done to assign attributes to an arc or delete the arc. A single arc is selected by left-clicking directly on it. Double-clicking on the arc will bring up the arc attributes dialog or that arc. Multiple arc can be selected at once by dragging a box. Additional arcs can be appended to the selection list by holding the SHIFT key while selecting by any method. Selecting new arcs without holding the SHIFT key will first clear the selection list and then add the newly selected points. A selected arc can be removed from the selection list by holding the SHIFT key as it is reselected. Pressing the ESC key will clear the entire selection list. Right-clicking will open a menu specific to this tool.

Feature arcs may have elevations associated with the arc as an entity. This is independent of the node and vertex elevations. When a single arc is selected, its elevation is shown in the Edit Window. The coordinates can be changed by typing in the edit field.

Multiple feature arcs may also be selected to create a feature arc group to associate attributes with a string of arcs rather than a single arc. These arcs must connect end to end. The arc group is created from the Feature Objects menu command.

The Graphics Window’s status bar will display information on the selected items depending on the settings find through the File | Info Options command in the File menu.

Selected arcs can be deleted by selecting the Edit | Delete menu command on the Edit Menu, by pressing the DELETE or BACKSPACE keys, or from the right-click menu. Nodes attached only to the deleted arcs are deleted.

This tool is available when one or more feature arcs exist.

SMS Create Arc Tool.svg Create Feature Arc The Create Feature Arc tool is used to create a new feature arc.


SMS Select Arc Group Tool.svg Select Feature Arc Group The Select Feature Arc Group tool is used to assign attributes to a string of arcs. The group must be created before it can be selected as a group. The attributes of the group then operate just as if the group was a single arc.


SMS Select Polygon Tool.svg Select Feature Polygon The Select Feature Polygon tool is used to select polygons to assign attributes to them. The attributes associated with the polygon depends on the coverage type. Double-clicking on the polygon will invoke the polygon attributes dialog for the polygon. Multiple polygons may be selected just as with arcs and nodes.

The polygons must be created using the Feature Objects | Build Polygons menu command.


Create 1D Grid Frame Tool.svg Create 1D Grid Frame The Create 1D Grid Frame tool only appears when the coverage is associated with a 1D grid model (GenCade). This tool is used to create a guide for the 1D grid that will be generated for a coastal morphology analysis.
Select 1D Grid Frame Tool.svg Select 1D Grid Frame Only appears when the coverage is associated with a 1D grid model (GenCade). This tool is used to select/edit the grid frame that is used to generate the 1D grid.


SMS Create Grid Frame Tool.svg Create 2D Grid Frame Used to create a new grid frame for the creation of Cartesiona grids. This tool is only available for coverages related to Cartesian grid models. The grid frame is defined by clicking three times in the graphics window. The first click defines the origin. The second click defines the I axis of the grid frame (both extents and direction). The third click defines the extents of the J axis. The direction is set to be perpendicular to the I axis.
SMS Select Grid Frame Tool.svg Select 2D Grid Frame Allows selecting a grid frame and altering its position, orientation and size. This tool is only available for coverages related to Cartesian grid models.
Select Compass Plot Tool.svg Select Compass Plot Allows sellecting a compass plot on a spatial data node. Available when using the Spatial Data coverage.

General Tool Right-Click Menus

The following is a list of options that appear in every tool's right-click menu:

  • Clear Selection – Undoes the selection of the object that was clicked on.
  • Invert Selection – Selects every object of the same type selected, and undoes the selection of the object that was originally selected.
  • Zoom to Selection – Causes the object selected to fill and be centered in the Graphics Window.

Tool Specific Right-Click Menus

Each tool in the Map module has its own right-click menu. When the object is selected, one can right-click and a menu will appear. The following is a table showing all of the different tools of the Map module with their respective right-click menus.

Tool Tool Name Right-Click Menu
SMS Select Node Tool.svg Select Feature Point or Node
  • Convert to Vertex/Vertices – Converts node(s) to vertex/vertices. Will not be available when selecting a point.
  • Delete – Deletes node(s).
  • Transform – Moves the node(s) either by scaling, translation, or rotation. User specified. See Data Transform for more information.
SMS Select Vertex Tool.svg Select Feature Vertex
  • Convert to Node(s) – Converts Vertex/Vertices to node(s).
  • Delete – Deletes vertex/Vertices
  • Transform – Moves the vertex/vertices either by scaling, translation, or rotation. User specified. See Data Transform for more information.
SMS Select Arc Tool.svg Select Feature Arc See the article Arcs for more detailed information.
  • Create Arc Group – Creates a group out of two or more arcs selected together.
  • Delete – Deletes the selected arc(s).
  • Split Arc(s) – Sub divides arc(s) at the vertices arcs based on a maximum length or at sharp corners. See Split Feature Arcs Utility for more information.
  • Offset Arc(s) – Invokes the Offset Arc dialog which prompts for offset distances and options to create one or more arcs offset from the selected arc(s). See Offset Arcs for more information.
  • Align Arc(s) with Contour – Moves the nodes and vertices of the selected arc(s) to the closest points on a contour at that value. See Align Arc With Contour for more information.
  • Redistribute Vertices – User specified distribution of vertices. Vertices can be evenly distributed based on spacing or number of vertices desired. See Redistribute Vertices for more information.
  • Reverse Arc Direction – Reverses direction of arc. The arc direction only impacts the direction of extracted 2D plots and the direction for defining a domain. See Reverse Arc Direction for more information.
  • Smooth Arc(s) – Repositions each vertex on an arc to smooths the arc(s). See Smooth Arc for more information.
  • Transform – Moves the arc either by scaling, translation, or rotation. User specified. See Data Transform for more information.
  • Attributes – Type specific. Many types do not have any attributes in their arcs. See Arc Attributes Dialog for more information.
  • Select Connected Arcs Turning Left – Selects the arc to the left of the originally selected arc. See Select Connected Arcs Turning Left for more information.
SMS Select Arc Group Tool.svg Select Feature Arc Group
  • Delete – Deletes Feature Arc Group(s).
SMS Select Polygon Tool.svg Select Feature Polygon
  • Delete – Deletes Feature Polygon (not the arcs that make up the polygon).
  • Attributes – Model specific.
Select 1D Grid Frame Tool.svg Select 1D Grid Frame
  • Properties – Invokes the Grid Frame Properties dialog that allows specifying the location, orientation, size and spacing of the grid frame using text fields; Specific to 1D grid coverages.
SMS Select Grid Frame Tool.svg Select 2D Grid Frame Type Specific
  • Properties – Invokes the Grid Frame Properties dialog where the 2D grid frame properties can be edited. Model specific.

Related Topics