WMS:Edit Menu

From XMS Wiki
Jump to: navigation, search


The Edit menu is one of the standard menus and is available in all of the modules. The commands in the Edit menu are used to select objects, delete objects, and set basic object and material attributes.

The Edit menu contains the following commands:

Delete 
The Delete command is used to delete any selected objects. This command is also equivalent to hitting the DELETE or BACKSPACE keys. A macro for the Delete command Delete Macro Icon.svg is found in the Macro tool palette.
Confirm Deletions 
Whenever a set of selected objects is about to be deleted, a prompt appears to confirm the deletion. This is meant to ensure that objects are not deleted accidentally. Selecting the Confirm Deletions item from the General tab of the Preferences dialog (accessed by the Preferences command of the Edit menu) can turn this option off. The check mark in front of the command is present when this option is turned off and is not when it is turned off.
Delete All 
The Delete All command is used to delete all of the data associated with the active module, whether or not there are selections. It is similar to the New command in the File menu except that the New command deletes all data in all modules.
Select All 
The Select All command (Ctrl+A) selects all items associated with the current selection tool, providing that the tool supports the Select All option.
Select With Polygon 
The Select With Polygon command allows entering an irregular polygon enclosing the items to be selected (one of the selection tools must be active). To enter the polygon, click on both the polygon's starting point and each intermediate point defining the polygon and double click on the ending point. All items within the polygon will be selected. If an error occurs while entering a polygon, the following keys can be used:
  • BACKSPACE or DELETE – Back up one line segment.
  • ESC – Abort entering the polygon, and selection by polygon.
  • CONTROL – Holding the CONTROL key down while moving the cursor causes all previously entered segments of the polygon to be moved simultaneously.
In addition to defining a polygon using the cursor, a polygon created in the Map module may be chosen to define a selection polygon.
Units 
WMS Units dialog
Units are determined by the data that is read into WMS. For example if a TIN is read in which has coordinate vertices in meters then WMS should be told that the project is working with metric units so that proper conversions are made when computing areas, slopes, and other geometric values.
Units are specified in the Units dialog. Model units are the units of the geometric data (i.e. TIN, DEM, feature objects, etc.) the project is using to develop hydrologic and hydraulic models whereas parameter units are the units to have areas and distanced converted to when performing calculations.
IMPORTANT: WMS requires that the Horizontal and Vertical units be the same in order to correctly estimate slopes.
Units are closely related to the current coordinate system and so access to this dialog is given in order to change the current units setting.
Units can also be changed in the Units toolbar
Reproject 
See Reproject for more information.
Single Point Reprojection 
The Single Point Reporjection dialog converting a coordinate (xyz point) between to coordinate systems. This dialog can be accessed from two locations within XMS programs:
  1. Edit menu, Convert Single Coordinate item
  2. Register Image dialog
The dialog consists of two sides. On the left side, the original (or Convert from) coordinate system is entered. On the right side, the final (or Convert to) coordinate system is entered. The options for the two sides are described on the Projections page.
The other items in the dialog include:
  • Enter coordinates – Enter the original (or from) coordinates.
  • New Coordinates – View the final (or to) coordinates.
  • Convert – Perform the conversion.
  • Create Mesh Node/Feature Point – Create a mesh node (if in the mesh module) or a feature point (if in the map module) at the final coordinates when OK is pushed.
Materials 
Materials Data dialog
When doing 1D hydraulic modeling in WMS it is useful to define material types. Cross section segments have material ID's associated with them and relate to the Materials defined with this command. These material types often represent different types of bed material or areas of fluid properties. A global list of material attributes is maintained that can be edited using the Materials Data command. The command brings up the Materials Data dialog where each material is assigned an ID number. This dialog can be used to delete unused materials, create new materials, and assign a descriptive name, color, and pattern to a material. This general information is saved in the material file.
The Legend toggle controls the display of a legend of the materials in the Graphics Window. The options for the legend are edited in the Legend Options dialog. These options include:
  • The name to be displayed on the legend.
  • The font to be used in the legend.
  • The specification of which corner of the screen the legend will appear in.
  • The size of each entry in the legend.
  • Whether all materials or active materials will be included in the legend.
When a new cross section is created, a user specified default material is assigned to the new section.
Material ID's can be assigned to polygons of an Area coverage and used to map to cross section segments when automatically extracting them from TINs.
Model specific material properties such as Manning's n are edited using commands local to the model menu.
The top material is the "Disable" material. Assign this material type to a feature object to remove a previously assigned material type. Objects with the "Disable" material type are read as though no material was assigned. The "Disable" material cannot be deleted.
Preferences 
Opens the Preferences dialog. See Preferences for more information.
Copy to Clipboard 
The contents of the Graphics or Hydrograph windows can be saved to the Windows clipboard by selecting the Copy to Clipboard command (Ctrl+C). The clipboard can then be “pasted” into other Windows programs, such as word processors or drawing packages.
Other dialogs and plot windows have separate commands available for copying text results or plots to the clipboard for inclusion in other documents.
WMS Copy To Clipboard dialog
Paste 
The Paste command in the Edit menu allows pasting tabular data (generally this is xyz data used to create a TIN or scattered dataset) directly into WMS. The tabular data can be copied from a text file or from a spreadsheet and then pasted into WMS.
When this command is executed the File Import Wizard is launched.

Obsolete Commands

The following commands are not longer available in current releases of WMS.

Coordinate Conversion 
Converts data from one coordinate system to another. See Coordinate Conversions for more information.

Related Topics