SMS:GIS Module Menus

From XMS Wiki
Jump to: navigation, search


The following menus are available in the the GIS Module:

Standard Menus

See SMS Menus for more information.

Module Specific Menus

Data

Most of the SMS modules have a Data menu, but the items in this menu are different for each module. The GIS Module commands include:

Enable ArcObjects  
ArcObjects® is a development platform provided by ESRI that allows developers of other applications (such as SMS 32-bit) to incorporate ArcView/ArcGIS® capability directly within their application. SMS can use ArcObjects® to access some of the same functionality in SMS that is available in ArcGIS®, providing SMS is running on a computer that has a current license of ArcGIS®.
The Data | Enable ArcObjects command queries the ESRI license manager for ArcView/ArcGIS® to see if a license exists. If a valid license is found then the ArcGIS® functionality within SMS is enabled and access will be allowed. If a license is not found then the ArcGIS® specific features remain unavailable.
Add Data
Select Data dialog
 
SMS uses ArcObjects® to incorporate much of the ArcMap® functionality directly. SMS can open any ArcGIS® supported file (coverages, shapefiles, geodatabases, images, CAD, grids, etc.) and use the ArcGIS® Display Symbology properties to render the GIS data and then display it in SMS.
The Add Data command is only available if ArcObjects® have been enabled. The Add Data command is used to open datasets and layers (*.lyr) files into SMS using ArcGIS®.
When ArcObjects® is enabled, SMS is able to load any of the ESRI supported formats, including shapefiles, coverages, geodatabases, grids, images, CAD files and others, as GIS data layers in SMS. These data can then be converted to feature objects in map coverages.
Add Shapefile Data  
The Add Shapefile Data command is only available if ArcObjects® have not been enabled. The Add Shapefile Data command is used to open a Shapefile (*.shp) into SMS.
Add MIF/MID File Data 
SMS uses ArcObjects® to incorporate much of the ArcMap® functionality directly. SMS can open any ArcGIS® supported file (coverages, shapefiles, geodatabases, images, CAD, grids, etc.) and use the ArcGIS® Display Symbology properties to render the GIS data and then display it in SMS.
The Add MIF/MID Data command is used to open a MIF/MID file (*.mif) into SMS using ArcGIS®.
Layer Properties  
The Layer Properties command opens the Select a layer dialog. The shapefile layer of interest is specified in the Select a layer dialog. Once the shapefile layer has been specified, the Layer Properties dialog is shown. See the ArcGIS® documentation for further explanation of the Layer Properties dialog. The Layer Properties command is only available if ArcObjects® have been enabled.
Map Properties
Map Properties Dialog
 
The Map Properties dialog is used when ArcObjects® is enabled to specify the coordinate system to display/map features from the ArcGIS® data layer. An ArcGIS® data layer should have a currently defined coordinate system associated with it. If the coordinate system is geographic (latitude/longitude), then ArcObjects® is able to "guess" correctly at the projection. Using the coordinate system as defined in the Map Properties, specify the coordinate system to use to display features/rasters. While this does not change the actual geometry of the layer, it will display in the main graphics window according to this projection and any data mapped to coverages will be mapped into the coordinate system specified by the Map Properties.
GIS layers can have an associated global projection. If a layer has an associated projection, the entities will be automatically displayed in the current project projection. GIS projection information can come from multiple sources:
  1. Files – ESRI shapefiles can have an associated *.prj file that contains the projection information. MapInfo MIF/MID files contain projection within the MIF file.
  2. Assigned in SMS – assigns a projection to a layer by right-clicking on the layer and choosing Coordinate Conversions. When doing this, SMS will save a PRJ file or a new set of MIF/MID files with the updated information.
The WMS article WMS:Map Properties has more information about this dialog.

Selection

The GIS Module Selection menu commands are only available if ArcObjects® have been enabled. The GIS Module Selection menu commands include:

Command Description ArcObjects® Required
Select by Attributes Opens the ArcObjects® Query Wizard Dialog. See the ESRI ArcGIS documentation for further explanation of the Query Wizard dialog. Yes
Select by Location Opens the ArcObjects® Select By Location Dialog. See the ESRI ArcGIS documentation for further explanation of the Select By Location dialog. Yes
Clear Selected Features Clears the current selection Yes
Interactive Selection Method Change the ArcObjects® selection options in use. Options include:
  • Create New Selection
  • Add to Current Selection
  • Remove from Current Selection
  • Select from Current Selection
Yes
Selectable Layers Opens the ArcObjects® Check Selectable Layers dialog. The layers to be selected can be specified. Yes

Mapping

The GIS Module Selection menu commands are only available if ArcObjects® have been enabled. The GIS Module Selection menu commands include:

Command Description ArcObjects® Required
Arc Objects → Feature Objects Opens the GIS to Feature Objects Wizard Yes
Shapes → Feature Objects Opens the GIS to Feature Objects Wizard No
Feature Objects → Geodatabase Saves the Feature Objects as a Personal Geodatabase file (*.mdb) Yes
Polygons → TIN Converts polygon data to TIN data that will appear in the scatter module. No

GIS Module Right-Click Commands

Right-clicking on an object in the GIS Data folder GIS Folder.svg of the Project Explorer pops up a menu of appropriate commands for the specific object type (static image, DEM, dynamic image, GIS coverage, ...) The following right-click commands are available for GIS objects. (Note: this list does not include any ArcObjects commands because this capability is not usually enabled.)

  • Delete or Remove – Deletes the GIS object from the project. This does not delete any file on disk (image files or GIS data files such as shapefiles) that are storing the objects.
  • Rename – Available for dynamic images and coverages. Allows specifying the name that appears on the Project Explorer. Apostrophes and special characters should not be used in the new name.
  • Transparency – Brings up the Layer Transparency dialog. Available for raster objects or images for both static and dynamic images.
  • Zoom to Extents – Frames and centers the graphics window to the extents of the selected object. Available for static images and DEMs as well as coverages. Since a dynamic image refreshes to whatever extents are being viewd, this command is not available for these objects.
  • Open Containing Folder – Launches a file explorer window in the directory containing a static image. The command is not available for other object types.
  • Projection/Set Layer Projection – Brings up the Object Projection dialog. This command is not available for dynamic images because.
  • Register Image – Brings up the Register Image dialog. Available for static images and DEMs.
  • Export – Brings up a dialog to resamples and save the image. Available for static images and DEMs.
  • Export World File – Exports a world file for the object that includes image registration data. Available for static images and DEMs.
  • Crop Collar – Turns on or off the optionally transparent pixels around the edge of an image. This is typical for USGS quad sheets. Available for static images and DEMs.
  • Interpolate To – This sub-menu appears for static images and DEMs. However, if the image does not have elevation data (DEM), the command does nothing. When the image has numeric data such as elevation or land use classifications (NLCD), a sub-menu for commands to interpolate the GIS object into another geomteric object in the project including:
    • 2D Mesh
    • 2D Scatter (both as regular scatter set and as land use data for ADCIRC nodal attributes)
    • 2D Grid
    • UGrid
    • Active coverage
  • Convert To – This sub-menu contains commands which vary with the selected object.
GIS Coverage – For a GIS coverage a sub-menu appears with the options to convert GIS points, arcs and polygons to geometric objects of another type along with any appropriate attributes. The conversion options include:
  • Shapes → Feature Objects – This command is a very powerful option for converting the feature points, arcs and polygons in the GIS coverage to feature objects in an SMS specific coverage. The command brings up a the GIS to Featue Objects Wizard. This allows the user to first specify the target feature coverage (which must be created before invoking this command) and the source GIS coverage or coverages to be converted. With the source and target specified, the next step of the wizard brings up the attribute mapping dialog (for polygons, arcs, or points depending on the type of GIS coverage(s) specified as the source).
The user then maps the source attributes from the GIS coverage to the attributes of the selected feature coverage based on the coverage type. This will create the geometric objects as well as assign their attributes.
  • Polygons → TIN – This command will convert all polygons in the GIS coverage to breaklines in a TIN and triangulate all the points.
Dynamic images – For a dynamic image, the only option for conversion is to convert to a static image. This will ask the user for a sampling ratio and a file name to create the static image. By default, SMS will load the static image into the current project.
Static images – For a static image or DEM a sub-menu appears with the options to convert to other data types. If the image does not have numeric data, it can only be resampled. However, if the image has numeric data such as elevations or land use classifications the following conversions are supported:
  • 2D Scatter – Each pixel is converted to a scatter point or vertex.
  • 2D Grid – A Cartesian grid is created with each pixel mapped to a cell.
  • Feature Contours – Contour(s) of the data in the DEM.
  • Feature Contours at Given Elevation
  • Resampled Raster – Creates a new DEM covering the bounds of the selected DEM with a specified spacing.
  • Smoothed Raster – Smooths the values on the DEM based on use specified weighting functions.
  • Trimmed Raster – Trims to the bounding box of a coverage or selected polygons.
  • Merged Raster – Appears when multiple rasters are selected. It creates a new raster that covers all selected rasters with a resolution set to the smallest cell size of any of the selected rasters.
See the article GIS Conversion and Editing for more information.
  • Editing – For DEM data (static images with numeric data), a sub-menu with the following commands:
    • Arc Elevation Profile – Brings up the Profile Elevations plot for a selected arc.
Example of the Attribute Table dialog using a shapefile
  • Open Attribute Table – The Attribute Table command opens the Attribute dialog. The attributes for each record in the specified layer can be viewed.
  • Join Table to Layer
    Join Table Dialog
    – Allows joining the attributes of one database file (*.dbf) to the features of a GIS layer based on a key attribute field. This is particularly important when the features are stored in a shapefile with a minimal set of attributes, and additional attributes are stored in a separate *.dbf file. The two files are related based on an attribute field named MUID. Other GIS data layers may be similar where the features contain some kind of key indexing field and the attributes are stored in a separate table that can be joined to the features based on the index field values.
After selecting the Join Table to Layer command a prompt will appear for the database file to join using the standard Select File dialog. The Join Table dialog will then appear and ask to select the Join Field from the GIS data layer attributes and the Join Field from the table being joined to the GIS data layer. Often these field names will be the same as in the example below, but they are not required to be the same. The important thing is that they contain similar information from which a join can be made. Finally, select to join all of the attributes from the join table or just add a specific field.
The join does not permanently alter the GIS data layer on the hard drive of the computer.
  • Convert to TUFLOW Rainfall Boundary Conditions – If the format is correct, the GIS data can be converted into TUFLOW rainfall boundary polygons on a TUFLOW 1D/2D BCs and Links coverage. For more information, see TUFLOW Boundary Conditions.

Related Topics